博文記錄
教程分享 2023-03-17 19:34:26 790 0

安装 iptables 时遇到了所依赖的 libxtables12 库版本不对。如果对其进行进行卸载就会默认对网卡进行关闭,导致无法连接到远程服务器。

所以这个是一个高危操作,谨慎!

# apt install iptables

...
The following packages have unmet dependencies:
 iptables : Depends: libxtables12 (= 1.8.2-4) but 1.8.7-1 is to be installed

1. 更新源

确保你的 Debian 11 系统的软件源是最新的,可以使用以下命令更新软件源

sudo apt update

2. 检查依赖关系

运行以下命令,检查 iptables 的依赖关系是否有问题。

sudo apt-cache policy iptables libxtables12

如果输出中显示了可用的版本与需要的版本不匹配,则需要更新版本或更改软件源。

不要去卸载它,你或许可以去进行忽略以来卸载,但不要在远程机操作,还是很高风险,不一定能够成功。如果你非要尝试,卸载时加上 --ignore-dependencies 

3. 安装指定版本依赖

如果你更换了源,运行以下命令更新软件源:

sudo apt update

稳妥的做法就是,安装指定版本的 libxtables12

sudo apt-get install libxtables12=1.8.2-4

4. 安装/更新

然后安装 iptables 

sudo apt-get update
sudo apt-get install iptables

或者更新 iptables

sudo apt-get update
sudo apt-get upgrade iptables
media iamge
StudioEIM - 冒险者讲习所
0:00